• Mikael Eriksson
    May 30, 2016 at 12:41 am #1955

    I am getting some strange problems when trying out the toolkit on BPM  8.5.7, I assume that they are related so I describe them all here.

    (It seems to be about the same on 8.5.6 when I tried  that download).


    First, I get an error dialog telling that I got a “Timeout loading module”. When looking in the javascript log this seems to be due to a fail to load BPMExt-Core-ConfigHelper.js, and later BPMExt-Core-Designer.js.

    The processapp has the SPARK UI toolkit and both Responsible coaches and the old Coaches as dependencies.

    Still with this problems I can do some editing but with limited functionality. Buttons does not show up in the designer at all (just an empty area that can be selected, the same goes for checkbuttons). Text fields and tables seems to work, at least for a while. But sooner or later the coach seems to end up in a state where it does not load at all, just showing the waiting wheel. (The same thing happens when bringing up a coach with buttons to select a boundary event when working in the diagram tab).



    /Mikael E

    SPARK Support
    June 1, 2016 at 2:36 pm #2005

    Hello Mikael,

    Our first inclination is to say that your server may be experiencing issues, and you are still trying to use the client in that state. Could you verify that the server is fully up and running, and that the BPM client has no issues communicating with it?
    Please look into this and provide us with any relevant server-side information that relates to the App/Spark/that environment.

    Also, the log file did not attach, so please provide a simple text file or any relevant parts of the log.

    Salient Support

    Mikael Eriksson
    June 1, 2016 at 3:28 pm #2006


    Thanks for your answer. We have not seen any issues for other coaches. Another thing worth mentioning (maybe 🙂 ) is that if I run the human service the buttons are shown, they are just invisible in the editor.

    And it feels strange that I can not find the files that are requested (BPMExt-Core-ConfigHelper.js, and BPMExt-Core-Designer.js) in the toolkit, where are they suppose to be?

    I did attach the log file again as a text file, it the last of the three attachments, csnbpm40.csnnet.int-1464593346676.txt.



    /Mikael E


    Mikael Eriksson
    June 7, 2016 at 4:52 am #2072


    The relevant lines from the console are  these:


    dojo.js?build=201603010316:2 Error: timeout(…)(anonymous function) @ dojo.js?build=201603010316:2(anonymous function) @ dojo.js?build=201603010316:2_9 @ dojo.js?build=201603010316:2req.signal @ dojo.js?build=201603010316:2(anonymous function) @ dojo.js?build=201603010316:2
    dojo.js?build=201603010316:2 src: dojoLoader

    dojo.js?build=201603010316:2 src: dojoLoader
    dojo.js?build=201603010316:2 info: Object {https://csnbpm40.csnnet.int:9443/rest/bpm/wle/pd/v1/managedAsset?containerRef=2064.4ba4e330-1cdd-45ff-afad-0262296bacbb&name=BPMExt-Core-ConfigHelper.js: 1, https://csnbpm40.csnnet.int:9443/rest/bpm/wle/pd/v1/managedAsset?containerRef=2064.4ba4e330-1cdd-45ff-afad-0262296bacbb&name=BPMExt-Core-Designer.js: 1}
    dojo.js?build=201603010316:2 declaredClass: uniqName_11
    dojo.js?build=201603010316:2 .

    When trying the rest call directly I get this response:

    {“status”:”error”,”data”:{“status”:”error”,”exceptionType”:”com.ibm.bpmsdk.rest.exception.api.ArtifactNotFoundException”,”errorNumber”:”CWMHW0326E”,”errorMessage”:”CWMHW0326E: Artefakten \”BPMExt-Core-ConfigHelper.js\” finns inte i systemet.”,”errorMessageParameters”:[“BPMExt-Core-ConfigHelper.js”],”programmersDetails”:null,”responses”:null,”errorData”:null}}

    “finns inte i systemet” means … “not found in the system”

    Trying to get another file (for example) BPMExt-Control-Button.js with the corresponding call worked.



    SPARK Support
    June 7, 2016 at 9:13 am #2074


    I’m still having issues seeing your log file attachment. Maybe you can put it on pastebin?

    I’ve spoken with the development team about this issue. Can you tell us if the coach was started in a different version of SPARK? As in, was part of the coach built in version X, and part of the coach built in version Y? The controls that are included in Community Edition has changed recently, so we’re wondering if that’s why you’re seeing the REST error that you’re reporting.

    Could you also check your validation errors to see if there are any broken coach view dependencies?

    SPARK Support
    June 7, 2016 at 10:27 am #2077

    After further discussion with the development team, we believe that these files should be in the Community Edition of SPARK and were removed. This only affects Web PD and how it looks on the coach designer. The coach will work properly at run time, and will work properly at design time if using Desktop PD. The issue has been logged and will be addressed in the near future.

    Thank you for reporting this to us.

    Mikael Eriksson
    June 7, 2016 at 12:31 pm #2079

    I’m glad you found the problem and looking forward to the new version!


    If there are any delays in the new version (and the only problem is that the files are missing) maybe you could put the files themselves up for download and then I could add them to the toolkit by hand.

    Edit: Just saw the main about the new version hoping its fixed there :). I will check that tomorrow.




    /Mikael E

    Mikael Eriksson
    June 7, 2016 at 11:39 pm #2081

    Seems that the files was not in

    Per Vedin
    June 9, 2016 at 5:57 am #2094


    I’m having the same problem. Just downloaded the Spark UI CE and the Spark Showcase and I’m also getting the errormessage “Timeout loading module. Server might be down.” when I try to open ex. Chart Notes CV Coach View (Spark Showcase).


    SPARK Support
    June 13, 2016 at 9:23 am #2118

    Hey Mikael + Per,

    Unfortunately, our release was just before this issue was found, and consequently the fix is not in that version. We should have the fix done in the next release of SPARK. We apologize for any inconvenience.

    -Elliot P.

    Per Vedin
    June 13, 2016 at 11:18 pm #2120

    When is the releasedate for the next version or is there any workaround I can use until then?

    Brian French
    June 14, 2016 at 7:58 pm #2152

    We release versions approximately every four weeks, so you can expect a new version sometime around July 8th.

    The workaround is to use Desktop Process Designer rather than Web Process Designer.  There are no issues when using Desktop Process Designer.

    Mikael Eriksson
    June 15, 2016 at 2:00 am #2154

    Since we are using 8.5.7 we can not use the Desktop Designer for Client side human services (and when checking in a heritage human service the components are not available at all, even though the examples are delivered as heritage human services.)

    Brian French
    June 15, 2016 at 12:52 pm #2169

    We have applied a hot fix. There is a version available for CE now.

    Mikael Eriksson
    June 16, 2016 at 12:40 am #2182

    I checked with and now it works :).  Thanks for quick fix.

    Per Vedin
    June 16, 2016 at 1:40 am #2183

    I’ve also tried the version and it works, but I can’t get any of the examples/showcases to work.

    Mikael Eriksson
    June 16, 2016 at 1:46 am #2185

    It seems like the showcases now contains the controls from the enterprise edition and not from the community edition. There are a lot more showcases than before. My guess is that the error is due the the enterprise toolkit is missing.


    Per Vedin
    June 16, 2016 at 1:50 am #2186

    It was also my thought, the error message mentions that the reference is not found

    Brian French
    June 18, 2016 at 6:08 pm #2199


    We will look into this on Monday.


    Brian French
    June 20, 2016 at 11:34 am #2219

    We have done a hot fix and made a new CE version available for download.  It is version

    Per Vedin
    June 21, 2016 at 2:05 am #2224

    Thank you for the update, now it’s working!

    Brian French
    June 22, 2016 at 7:50 pm #2227

    Glad it fixed your issue…

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Start typing and press Enter to search